Chatfuel no borra e...
 

Chatfuel no borra el caché de entrada del usuario  

  RSS

danovis
(@danovis)
New Member
Registrado: hace 8 meses
Respuestas: 3
20/04/2019 11:15 pm  

Hola, me llamo Danovis.

Estoy creando un motor de búsqueda de vuelos mediante el uso de chatfuel, flowxo y google. Cuando ejecuté el chat por primera vez, funcionó perfectamente, pero cuando lo ejecuté de nuevo, solo mostraba los resultados de búsqueda que contenían la entrada de la primera vez que ejecuté y no de la segunda/tercera/cuarta vez. Sin embargo, si espero algún tiempo, 15-20 minutos, el bot funciona como debería de nuevo. Creo que tal vez el problema es que el chatfuel no limpia el caché o no procesa las respuestas de Json lo suficientemente rápido. ¿Alguien ha encontrado este problema y/o sabe cómo resolverlo?

Danovis.

This topic was modified hace 8 meses by danovis

Citar
tacorlius
(@tacorlius)
Eminent Member
Registrado: hace 8 meses
Respuestas: 32
21/04/2019 12:28 am  

El script de consulta debe usar encabezados para bloquear caché. No se trata de cache de chatfuel sino del servidor en donde reside el script de consulta. Q se fije en las configuraciones de caché del htaccess del server o config de apache. Ojo esto mismo te podria pasar con JS o CSS cuando usas webviews y se debe a lo mismo.

Cristián


ResponderCitar
danovis
(@danovis)
New Member
Registrado: hace 8 meses
Respuestas: 3
21/04/2019 12:48 am  
Respondido por: tacorlius

El script de consulta debe usar encabezados para bloquear caché. No se trata de cache de chatfuel sino del servidor en donde reside el script de consulta. Q se fije en las configuraciones de caché del htaccess del server o config de apache. Ojo esto mismo te podria pasar con JS o CSS cuando usas webviews y se debe a lo mismo.

¿Y sabes como configurar el archivo .htaccess en el servidor?

agradezco tu ayuda amigo!!!

This post was modified hace 8 meses by danovis

ResponderCitar
Share:

Por favor Iniciar Sesión o Registro